Jag fick ganska nyligen en Genesi Smartbook av min vän Linus. Det är en kul liten maskin på under 1 kg helt utan rörliga delar.

Den är byggd runt en Freescale i.MX515 SoC med en ARM Cortex-A8 (ARMv7) på 800MHz och 512 meg RAM. Det är 16 gig fastlödd SSD på den men det finns plats för SD och microSD. Den är alltså ganska långsam och har lite ont om resurser jämfört med andra netbooks och ultraportabla laptops.

Den bootar trots sin sega CPU ändå snabbt. Det tar 16 sekunder från att jag trycker på strömbrytaren tills jag har en login-prompt i console. Det tar 6 sekunder att starta X och få en prompt som frågar efter min SSH-lösenfras. Direkt efteråt har jag en terminalemulator att börja arbeta i, snabbare om jag skippar X, förstås.

Shutdown tar 4 sekunder. Jag har inte fått suspend att fungera. Någon som fått det att fungera?

Dess största nackdel är att en ganska blank skärm:

En spegel?

och att den inte har trådat nät. Det senare löste jag med ett USB Ethernet som jag hittade på som noname-produkt på Claes Ohlson för 200 spänn! Det är i själva verket en Good Way AE2220 och fungerar både under Linux och FreeBSD.

För att göra burken lite mer användbar stängde jag av en massa saker. Med 512 meg RAM och seg CPU vill man inte köra en full Gnome-desktop, om man nu någonsin vill det. I stället kompilerade jag mcwm på den och försöker låta bli att köra tungrodda Firefox eller Chromium på den. Det är ganska slött. Emacs, en bunt urxvt och lite kompileringar fungerar bra på den och som SSH-terminal fungerar den utmärkt.

Jag har också mappat om det amriska tangentbordet till min egen svenska layout både i console och i X. Jag slänger upp konfigurationsfilerna för det någonstans snart. Hojta till om ni vill ha dem och det är bråttom.

Knapparna för backlight fungerar inte i min miljö, så jag skrev ett litet tämligen trivialt program för att sätt backlight-nivån. Publiceras snart. Dito för batteriindikatorn.

Tyvärr är burken lite instabil. Den kraschar ibland men den har aldrig kraschat när jag arbetat på den. Jag tror det har något att göra med någon strömsparfunktion, kanske för skärmen. Även om jag slår av skärmsläckaren med "xset s off" så slår den nämligen av skärmen. Ibland går den inte att väcka. Jag har inte haft tid eller möjlighet att debugga.